I cannot read the CHM reference docs

Topics: General discussion
Oct 11, 2014 at 2:37 AM
I downloaded the ref docs in CHM format "Enterprise Library 6 Reference Docs REMEMBER TO UNBLOCK.chm"
I am on Windows Server 2012 R2 Data Center 64 bit.
There is NO Unblock button. I am familiar with this. So this is not a naïve error on my part. Something else is going on. The CHM file opens and I can read the index, but all the contents are blank.
Oct 14, 2014 at 1:17 AM
It certainly sounds blocked but it's odd that there is no Unblock button. Perhaps try using powershell to unblock the file?
powershell  "Unblock-File '.\Enterprise Library 6 Reference Docs REMEMBER TO UNBLOCK.chm'"
~~
Randy Levy
entlib.support@live.com
Enterprise Library support engineer
Support How-to
Oct 15, 2014 at 1:15 AM
Edited Oct 15, 2014 at 2:01 AM
I'll try your suggestion.
thx
Oct 15, 2014 at 2:13 AM
yes, that did it. Apparently the file was blocked but the UNBLOCK button was not present. Using the powershell command fixed it.
However, before I used the powershell unblock-file .... command, what I was seeing when I tried to open it was an error message like this
Open File -Security Warning 
Do you want to open this file? 

Name: C:\users\.......chm 
Publisher: Unknown Publisher 
Type: Compiled HTML Help file 
From: C:\users\.......chm 

While files from the Internet can be useful, this file type can potentially 
harm your computer. If you do not trust the source, do not open this 
software 
I would press the OK button but that would merely open the file and the content was blank.
Once I unblocked it using the powershell command unblock-file, I could double-click the CHM and it worked fine. No warning dialog popped up, and the content appears.

I have seen similar issues with other applications at my workplace. I think we have some strict policies in place that seriously hinder opening any files that do not have a trusted publisher. I'm putting all this detail in here in case someone else has such policies.
Oct 15, 2014 at 2:39 AM
Here are some tools for others who may have similar problems. These powershell scripts are able to reveal which files are blocked even if the UI (as in my case) does not reveal this.
http://blogs.technet.com/b/heyscriptingguy/archive/2011/04/02/scripting-wife-learns-about-unblocking-files-in-powershell.aspx
http://technet.microsoft.com/en-us/library/hh849924.aspx
Oct 15, 2014 at 2:51 AM
Good to hear it's sorted out and thanks for posting the additional info.

One thing I will say about using streams -d is that it deletes all streams and not just the zone data. This is probably not a big deal most of the time but it could be an issue if a file had other streams.

Thanks, again,

~~
Randy Levy
entlib.support@live.com
Enterprise Library support engineer
Support How-to