Exception after deploying my website using Ent. Lib

Topics: Exception Handling Application Block
Jan 29, 2007 at 11:11 AM
Dear all,

after i deployed my website,and i did nmy site using Ent. Library 2.9,i got this error.

Required permissions cannot be acquired.

Exception Details: System.Security.Policy.PolicyException: Required permissions cannot be acquired.

the problem is that the default trust level for asp.net is not full trust is a partial trust,and i changed the security level on the web.config but the problem is still there ????

any one can help ?????

Jan 29, 2007 at 6:40 PM
Hello,

Not sure if his is any help, but under the releases tab, there is a special patch to allow entlib to run under partial trust.
Perhaps you should take a look at it. I haven't worked with it myelf, so I can't give you more info.

Best regards,
Ike
Jan 30, 2007 at 1:13 AM
I assume the partial trust patch they created for Enterprise Library 2.0 made it into the current version.

I haven't tried to deploy it in a partial trust environment yet since it hasn't made it to production status. There may be something unfinished in that area.

If you can't solve the problem and you think it is definitely a problem with partial trust, I would add it to the Issue Tracker to make sure it gets documented.

Regards,

Dave

_______________________

David Hayden
Microsoft MVP C#