Enterprise Library 4.1 installation error

Topics: General discussion
Oct 30, 2008 at 4:03 AM
I just got the 4.1 bits and went to install and I receive a dialog box stating that 4.1 cannot be installed side-by-side with Ent Lib 4.0. <argh!> So, I uninstalled 4.0, reboot, go to install and get the same error dialog. I'm running Vista Ultimate, Visual Studio 2005 and 2008. I also have EntLib 3.1 installed.

Can someone please help?


Oct 30, 2008 at 9:12 AM
No answer yet, but you're not alone. I got the exact same error, but it was on a machine that I had been doing entlib dev work on, so I assumed that it was just me. And then I repaved it, so no help there.

Other people have reported the same error. I'll be looking at it first thing in the morning.

Oct 30, 2008 at 1:49 PM
Edited Oct 30, 2008 at 1:53 PM

Hi, i have the same error but in a different situation. I did this experiment to repro the error.

I'm using Windows Server 2003 R2 with VS 2005 and 2008. Also with Ent Lib 3.1 Installed.
My steps are as follows:

1. Installed Ent Lib 4.1 -> Install Success.
2. Installed Ent Lib 4.0 -> Install Success.
3. Uninstall Ent Lib 4.1 -> Failed (Error)
4. Uninstall Ent Lib 4.0 -> Uninstall Success.
5. Uninstall Ent Lib 4.1 -> Failed. Same error as step # 3.
6. Search and deleted all Enterprise Library 4.0 related registry entries in the regedit.
7. Uninstall Ent Lib 4.1 -> Uninstall Success.

Try deleting all the Ent lib 4.0 related registry entries.

NOTE : I just used the "Enterprise Library" as my search key in the regedit.

Hope this helps.


Oct 30, 2008 at 2:30 PM

Removing the key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Enterprise Library v4" from the registry should allow the install.
The issue with the MSIs for 3.1 and 4.0 is that there are some duplicate component IDs. When uninstalling, reference counting kicks in and some components, like this registry key, are not deleted and must be manually cleared.

Oct 31, 2008 at 4:27 AM
Thanks Fernando, that fixed it for me!
Nov 3, 2008 at 4:07 PM
Removing the key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Enterprise Library v4" from the registry

That works for me.
Dec 1, 2008 at 4:42 PM
Thank you very much!  Removing the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Enterprise Library v4 entry from the registry worked for me too.
Jan 13, 2009 at 9:10 AM
Thanks, worked for me too.
Jan 28, 2009 at 10:37 PM
Removing registry entry worked for me too.
Feb 3, 2009 at 9:46 PM
I am receiving this error on a Windows Server 2003 machine (64bit), but there is no registry key to remove.
Has anyone else seen this problem?
I have unintsalled 4.0 but I can't install 4.1 
Feb 4, 2009 at 6:28 AM
Did you try to look for other EntLib 4.0 registry entries and delete them?

Sarah Urmeneta
Global Technology & Solutions
Avanade, Inc.
Feb 15, 2009 at 4:13 AM
Also had the problem on a Windows 2008 (64bit) machine. Registry entry above not there. But after searching for "Enterprise Library" and removing it....installation of 4.1 worked.
Apr 30, 2009 at 4:49 AM
Under x64 based system the key to delete is:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Enterprise Library v4

Tested in Windows XP 64!

Hope this helps.