Using 3.1 together with 4.0 web.config problem

Topics: Data Access Application Block
Aug 7, 2008 at 12:32 PM
Hi!

I'm trying to upgrade Entlib to version 4.0.

How do I setup my web.config so that I can use both 3.1 and 4.0 at the same time? I have older projects that rely on 3.1 so I can not remove the support for them.

I've tried configuring the web.config in many different ways but none seem to work.

How do I go about doing this?
Aug 7, 2008 at 5:43 PM
Hi,

Unfortunately you can't have configuration for different versions of EntLib in the same configuration file using the signed binaries, since the section names are not versioned. However, you can probably make it work if you can afford to modify the source to use different section names for different versions of EntLib and deploy your own binaries.

Fernando