Bug: Integration with Visual Studio IDE

Topics: Pre-release discussions
Dec 28, 2006 at 9:47 AM
I have installed my visual studio 2005 on the D:\ drive. I have installed EntLib December CTP. Now when I try to open an application configuration file I receive the following error:

Microsoft Visual Studio
Could not find a part of the path 'C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PublicAssemblies'.

I have tried to see if this value is being retrieved from the registry or config file but apparently this has been hardcoded in EntLib 3.0. Note that this folder does exist but on my D drive.
Dec 28, 2006 at 6:47 PM
If this is indeed a bug and you are stuck at the moment, I recommend just changing the default configuration editor used for editing .config files in Visual Studio until a better answer is available.

The EntLib installation appears to set the new Enterprise Library Configuration Editor to the default editor. I wrote a tutorial here:


that shows you how to right-click on your app.config or web.config, choose open with..., and just click on a different editor and set it as default.




David Hayden
Microsoft MVP C#
Dec 29, 2006 at 1:28 AM
Thanks Gabriel - that's why we call it a CTP :-). We'll look into it and hopefully it will be fixed for the next CTP. BTW I've seen another report about a problem that looks like is caused by the same bug - if you install EntLib on a non-English Windows machine where "Program Files" is localized into a different language, the VS-integrated tool will not work either. Globalization testing takes some time and was out of scope for the CTP, but we'll be doing plenty of testing to catch these types of issues before the final release.

Dec 29, 2006 at 1:03 PM
Ops. I didn't see this topic in the forum and I opened an Issue with Issue Tracker.

Dec 29, 2006 at 4:06 PM
Thanks for this feedback.
If you haven’t installed your Visual Studio underneath c:\Program Files\ there still might be a workaround for this bug.

I think the easiest way around this is bug is to:
1) Create a temporary directory hierarchy under your c-drive to match the expected directory “c:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PublicAssemblies”
2) Copy all of the Microsoft.Practices.* dll-files from your actual “VSInstallDir\Common7\IDE\PublicAssemblies” to the directory you created.

Not a pretty workaround, I agree. But given a choice between errors using the Integrated editor or creating this temporary directory containing a copy of the entlib dll’s –I’d go for the second option.

Hope that eases the pain – unfortunately I couldn’t test it on a non-english Visual Studio installation myself.