AzMan provider - file schema version

Topics: Security Application Block
Oct 30, 2010 at 10:31 AM

When I come to create a new AzMan store using the MMC Snap-In on Win7, I get offered the choice of a version 1.0 or version 2.0 schema.  Was EntLib designed to work with a specific version?  Is there a preference?

Nov 2, 2010 at 9:09 AM

I used the raw APIs from the Microsoft.Interop.Security.AzRoles assembly being used by EntLib 5.0's AzManAuthorizationProvider with xml stores using both version and both worked.  I haven't tried using the AzManAuthorizationProvider itself, exploring passing parameters, I'm still trying it out. 

 

Sarah Urmeneta
Global Technologies and Solutions
Avanade, Inc.
entlib.support@avanade.com

Nov 3, 2010 at 2:07 AM

I have tried out using the AzmanAuthorizationProvider with both schema version and verified that it works also with both. 

 

Sarah Urmeneta
Global Technologies and Solutions
Avanade, Inc.
entlib.support@avanade.com