Does EntLib Work under XP ?

Topics: Enterprise Library Core, General discussion
Apr 23, 2010 at 12:13 PM

Hi All,

what abou tWindows XP ? I do not see it here

Enterprise Library 5.0 Final Release System Requirements:· Operating system: Microsoft Windows® 7 Professional, Enterprise or Ultimate; Windows Server 2003 R2; Windows Server 2008 with Service Pack 2; Windows Server 2008 R2; or Windows Vista with Service Pack 2. · Microsoft .NET Framework 3.5 with Service Pack 1 or Microsoft.NET Framework 4.0.


Does it mean that EntLib does not work under XP ? 



Apr 23, 2010 at 2:30 PM


I'm running XP SP3 with VS 2008 and VS 2010 and the EL 5 installs and works fine.  They probably don't mention it because very soon they will no longer be supporting Windows XP SP3, especially with VS 2010 and EL 5.

William D Howell Sr

Apr 23, 2010 at 10:18 PM


Typically we, at patterns & practices, go back two OS releases when defining our platform test matrix.

That's why Windows XP is not listed in the system requirements since we haven't done as rigorous testing on it as we've done on the listed OSs. Having said this, you should be able to use Enterprise Library on Windows XP with .NET Framework 3.5 SP1 or .NET Framework 4.0 installed. Several beta testers also confirmed this. William (thanks for the post!) also testifies that it works fine.

- Grigori

Apr 28, 2010 at 10:20 AM

4/28/2010 Update: Additional test pass on Windows XP conducted, no issues found!


May 27, 2010 at 10:29 AM

I am using Win 2008 with VS 2010. While installing EntLib 2010 I get a message that I need .net 3.5 SP1, where as either 3.5 SP1 or 4.0 is a minimum requirement and I already have .net 4.0

May 27, 2010 at 3:33 PM

XP is supported.  Check my reply below and the feedback from the coordinator.

William D Howell Sr.