EntLib 5.0 binaries targeting .NET 4.0

Topics: General discussion
Apr 22, 2010 at 12:52 PM

Do you plan to release binaries that target the .NET 4.0 framework and only depends on assemblies that target .NET 4.0?

Apr 22, 2010 at 1:07 PM

I wouldn't count on such a release because majority of the votes wanted entlib 5 to target .net 3.5.  However, you might be interested on this person's work - http://entlib.codeplex.com/Thread/View.aspx?ThreadId=83886.  It's very likely he'll create one for the official release of entlib 5.

 

Sarah Urmeneta
Global Technology and Solutions
Avanade, Inc.
entlib.support@avanade.com

Apr 22, 2010 at 4:05 PM

We have plans to do so. Entlib doesn't do anything that would take advantage of .NET 4.0, and just because it targets 3.5 doesn't mean it also loads the 3.5 framework, everything still runs under a single version of the CLR. It also radically complicates our build process, installer, and future releases.

If I may ask - why do you want this? Some people have asked but I can't think of any actual value to it; I'd love to be educated as to why.

If you want a 4.0 targetted binary, you can build the entlib source using VS 2010 - the 2010 project files target .NET 4.0.