Validation.Validate(some object) not working

Topics: Enterprise Library Core, General discussion, Validation Application Block
Feb 26, 2010 at 8:23 PM

Hello,

I recently started having difficulty with this particular call; Validation.Validate(some object). No matter if there is invalid within the object passed into to the Validate method the results always come back as valid. Any hints as to what could be happening? I am not doing anything fancy; no custom validators are being just a simpe range validator.

Feb 26, 2010 at 9:41 PM

I just tried to bring up my app.config; which points to my external config file that house my validation rules, and I think I may have more more closely narrowed down my issue. This is the error I got when I try to bring the app.config file up with EntLibConfig.exe.

'Microsoft.Practices.EnterpriseLibrary.Configuration.Design.VisualStudioIntegration.EnterpriseLibraryIntegrationPackage, Microsoft.Practices.EnterpriseLibrary.Configuration.Design.VisualStudioIntegration, Version=3.0.0.0, Culture=neutral, PublicToken=b03f5f7f11d50a3a' has failed to load properly ...

I am not sure how to resolve this issue, but I did find an article to talks about it, but there was no clear solution given to solve it. Again any help would be GREATLY appreciated!

Article Link: http://blogs.msdn.com/tomholl/archive/2007/04/19/avoiding-configuration-pitfalls-with-incompatible-copies-of-enterprise-library.aspx

Mar 1, 2010 at 2:15 AM

What version of entlib are you using here?  From the error you posted, it's v3.0 but you have other active posts here and you mentioned you're using v4.1.  Do you have both versions installed?

 

Sarah Urmeneta
Global Technology & Solutions
Avanade, Inc.
entlib.support@avanade.com

Mar 1, 2010 at 1:23 PM

I am using v4.1. I merely copied and pasted that error message; mentioning the version 3.0, from another posting that I saw that had the same issue I am facing.

Mar 2, 2010 at 7:35 AM

Have you tried uninstalling and re-installing the ent lib 4.1?

Mar 2, 2010 at 1:31 PM
Not yet. I am hoping that will have to be my very last resort.


From: [email removed]
To: [email removed]
Date: Mon, 1 Mar 2010 23:35:29 -0800
Subject: Re: Validation.Validate(some object) not working [entlib:201469]

From: AvanadeSupport
Have you tried uninstalling and re-installing the ent lib 4.1?
Read the full discussion online.
To add a post to this discussion, reply to this email (entlib@discussions.codeplex.com)
To start a new discussion for this project, email entlib@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com
Mar 3, 2010 at 1:32 AM

If you right click on a configuration file of a visual studio project, does the option to open it with the Enterprise Library Configuration Tool exists?  If yes, if you tried to open your config in the entlib configuration tool, does it open within the visual studio IDE or outside of it?  You may want to check this out - http://entlib.codeplex.com/Thread/View.aspx?ThreadId=48201

 

Sarah Urmeneta
Global Technology & Solutions
Avanade, Inc.
entlib.support@avanade.com