CreateDatabase delegation and Anonymous

Topics: Data Access Application Block, Logging Application Block
Nov 9, 2007 at 7:20 PM
Hi all,
I got this problem: an application .net aspx 2.0 running on a win2003 frontend and using a win2003 sql backend.
In this scenario there's IPSec and SSL.
The .net application use Enterprise library 3.1 and try to use CreateDatabase("connectionname") where connection name
is in the config file.
Actually everything goes ok just the time i run the application on the frontend, but when i try to run the site from
another station of the .net i got an exception that say me that is impossible grant the access to sql to the anonymous user
(that's right, i want it but the problem is the user is authenticated).
If right before the createdatabase i check the identity taking it from the context i see the right user that got the
rights to access, read and write on the db.
Someone can give me a good explenation of it? i tried to enable delegation too but without success.
another check i done is open the connection directly using sqlopenconnection and i dont get errors..then my guess is something
wrong with E.L....

Thanks everyone.

PS the same with logging since for this I use the same db-server
Nov 9, 2007 at 7:35 PM

Can you post the actual exception you get? Where does it fail exactly: when trying to create the database or when trying to do something with it?

EntLib's DAAB is really a thin wrapper on top of ADO.NET 2.0. Can you verify what you are trying does work with plain ADO.NET? You can try just by doing new SqlConnection([your connection string]).Open();.

Nov 9, 2007 at 8:36 PM
Edited Nov 9, 2007 at 8:37 PM
Hi fernando,
now i cant reproduce it (i'm out of the network) but the exception raise when i try to execture CreateDatabase of databasefactory using the connectionstring in configuration file and says more or less "impossible to access to the db using anonymous".
using sqlconnection open with the same connection string all work correctly but actually i use a lot of E.L and the log too is with it so i want to understand why it fails and keep using it if possible...sounds strange but sqlconnection open works...createdatabase nop....

both work right if i'm running it from the same frontend machine but the problem raise when i try from another domani machine.
Nov 10, 2007 at 3:49 PM
another information:

the dll of EL are in the bin of the web application and not deployed in GAC, could be this a problem? is needed other configuration than the connection string?

thanks again
Nov 12, 2007 at 12:04 PM
Hi Giuseppe,

Please post the exception details (ie type, message, stack trace, whether there is an inner exception, etc)