Missing VS GUI Config Editor for EL

Topics: General discussion
Nov 14, 2009 at 2:38 AM

When I right click on an App.config file I expected to see the EL configuration selections menu; it is not there. 

I've added to the project references to EL Common, ObjectBuilder2, and EL Data -- if that makes any difference.    

Using VS 2008 SP1 and installed EL 4.1 for October.   The Installed Products of About VS shows EL Configuration Editor 4.0.

TIA, Jim

Nov 15, 2009 at 6:17 PM


Have you tried to do a uninstall and re-install of Enterprise Library?

Valiant Dudan
Global Technology and Solutions
Avanade, Inc.

Nov 16, 2009 at 1:00 AM

Thank you Valiant.  Yes.  I used Control Panel's Add/Remove Programs to remove Enterprise Library, re-downloaded, and re-installed. The location is the default "C:\Program Files\Microsoft Enterprise Library 4.1 - October 2008".

I had originally installed just the Unity block -- I saw no uninstall for that and did not think that was a problem.

I don't see any "proof" that EL is incorporated into VS except the noted "Enterprise Library Configuration Editor 4.0" in the Help -> About -> Installed Products. 

When I run the EntLibConfig.exe in the package, I get a very blank form with nothing to do.  The Help -> About shows Configuration TOol version  Nothing selectable except New and Add Application.

Thank you,



Nov 16, 2009 at 5:45 AM

Hi Jim,

I also have a Ent lib 4.1 installed. I'm running on VS 2008 SP1. Yes, I saw that there is the "Enterprise Library Configuration Editor 4.0" in the "Help -> About -> Installed Products", not sure why it is tagged as 4.0 even it is really the ent lib 4.1. Anyways, can you please look at "Tools > Package Load Analyzer" and find the Microsoft.Practices.EnterpriseLibrary.Configuration.Design.VisualStudioIntegration.EnterpriseLibraryIntegrationPackage(if it exists there), then right-click "Analyze" to see if there are errors about the VS integration package of the ent lib.

when you run the "EntLibConfig.exe", did you tried adding application? just to see that the standalone tool works.

What OS are you running on? Do you have administrative rights?

Valiant Dudan
Global Technology and Solutions
Avanade, Inc.