Enterprise Configuration Tool In VS2005

Topics: Enterprise Library Core
Jan 31, 2007 at 5:03 AM
Edited Jan 31, 2007 at 5:04 AM
If this has been discussed, I appologiize, but I have recently started playing with Ent Lib 3.0. Strangely enough, the Enterprise Configuration Tool runs fine independently, but when I double click an app.config file in VS2005 solution explorer, it opens the app.config file in the tool (hosted in VS2005) but I only get two lines. Line 1 is "Enterprise LIbrary Configuration". It is expanded to show the app.config file below it (Line #2). The context menu's are ghosted out with "new" and "Rename". I cannot expand the app.config file (there isn't even a plus next to it).

My system is as follows:
Vista Ultimate x64
Ent Lib 3.0 Dec.
VS 2005 (With Vista Patch 050727-8500).
My visual studio 2005 is run as admin.

What am I doing wrong?
Jan 31, 2007 at 2:02 PM
I know some developers are having problems with the Configuration Editor while it is still in CTP and the EntLib team is looking into the problem(s). I recommend downloading the latest version - January 2007 CTP - in case the new version fixes your problems.

Maybe Tom can tell us more about the support for Vista right now. I know we are still awaiting a service pack for VS 2005 for Vista, so I am not sure there is full support for Vista until the VS 2005 Service Pack is released.




David Hayden
Microsoft MVP C#
Jan 31, 2007 at 4:17 PM
Thanks for the suggestion on Jan CTP..I will try.

If I were a betting man, I was think it has to do with Vista's UAC, and the fact that Microsoft suggest that VS2005 be run with Administrative Privledges. I fought a Drag N' Drop issue related to UAC for hours before I decided that it wasn't my fault, and found some info on the web mentioning that when a drag n' drop tries to go from a non privledged process (i.e. Windows explorer) to my program running under VSHost (A Privledged program), the UAC simply pretends like there isn't any Drag N' Drop going on...Ouch....that was a waste of time.

Another side note on UAC and VS2005 running as an admin is the following:
In one of my projects I have a RTF file that is a release notes file. I used to be able to double click it and MS Word would open to edit it. Now, because of UAC, when I double click the RTF file, nothing happens. I believe UAC is intercepting that launch (From a Admin process to a non admin process) and blocking it (Silently I might add).

Feb 2, 2007 at 7:03 AM
I installed Jan CTP and the Configuration Editor Issue in VS2005 went away!

Thanks for the great work!