Enterprise Library for .NET 4.6

Topics: Enterprise Library Core, General discussion, Pre-release discussions
Jan 6 at 4:37 PM
Hi all,

The last version of the library supports .NET 4.5. Will there be an upgrade to the library to support .NET versions 4.6+? Does anyone know?

Thanks.
Jan 6 at 4:48 PM
It doesn't appear right now that there will be an Enterprise Library that explicitly targets .NET 4.6+. However, I think you should be able to use Enterprise Library with .NET 4.6+ even though it isn't "supported" (since development predates that .NET version).
Coordinator
Jan 19 at 10:20 PM
Hi Siminder,

Randy is correct. We are no longer actively developing Enterprise Library. However, the source will continue to remain available.
This doesn't actually change the support scenario because our support channels have always considered use of Ent Lib to be customer code.

Sincerely,
Christopher Bennage
Feb 24 at 2:59 PM
Edited Feb 24 at 3:01 PM
Hi Ben:

Two questions:

1) Where can the latest version of the 6.X source be found? The packages available on Nuget look to be later than the source available on the MS Download site.

2) Where can I find the development site for 7.X?

Thanks

marc