Enterprise Library 4.1 with .Net 2.0

Topics: General discussion
Aug 6, 2009 at 4:10 PM

MS documentation states .Net 3.5 as a system requirement to use ent lib 4.1. Can we use this with .net 2.0?

Aug 7, 2009 at 3:49 AM

Hi,

Yes. I may say it will work. But the thing that I'm not sure is, if it will work on all scenario that you may think of. I have tested ent lib 4.1 on a .NET 2.0 application and it seems to work fine. I just tried it on a very simple scenario which is to log something in the event log and it works. What I'm thinking is that it wont work for the cases that requires .NET 3.5, such as WCF integration which I think is not available on .NET 2.0.

Valiant Dudan
Global Technology and Solutions
Avanade, Inc.
entlib.support@avanade.com

Aug 10, 2009 at 5:53 AM

Entlib 4.1 is not supported on .NET 2.0. It may work in some cases. There are other things (like WMI instrumentation) that I guarantee will not work. If you try running it on 2.0, you're on your own.