Enterprise Library compatibility with VistaDB

Topics: Data Access Application Block
Aug 4, 2009 at 12:32 AM

Could anybody please tell me if VistaDB is supported in the Enterprise Library DAAB?  If not, is there any planned support for it?

Aug 4, 2009 at 2:58 AM

I believe it is not directly supported and you would have to create custom classes.  If the information mentioned here http://weblogs.asp.net/bhouse/archive/2005/07/28/420899.aspx still applies to the current VistaDB version, you would have to create a DbProviderFactory for VistaDB and make use of the GenericDatabase class of Entlib.  Support for VistaDB is not included in the current product backlog for EntLib 5 (http://blogs.msdn.com/agile/archive/2009/04/16/enterprise-library-5-0-product-backlog-prioritization-results.aspx).  Besides, the latest version of entlib is already built in .Net 3.5, VistaDB is just starting to migrate from 2.0 to 3.5 (http://download.vistadb.net/About.aspx). 

 

Sarah Urmeneta
Global Technology and Solutions
Avanade, Inc.
entlib.support@avanade.com