EntLib Configuration Util cannot save onto a shared drive

Topics: Enterprise Library Core, Logging Application Block
Jul 6, 2009 at 11:52 PM
Edited Jul 6, 2009 at 11:54 PM

Pardon if this is a cross-post. I tried to find an ongoing issue or discussion but has failed thus far. 

I have EntLib 4.1 with VS2008. I am editing web.config via EntLib Configuration Utility for a project located on a shared drive (roaming profile with my docs centralized), and it appears that always errors out with "One or more errors occurred while trying to save the configuration" when I attempt to save the config file to a disk.  I've moved another sample project that exhibitted same behavior, locally, and that error went away.

I have increased the LocalIntranet zone trust to "FullTrust" but not sure if that applies here as i would supposed the config util assembly is on my local workstation drive somewhere.  Anyone had a problem like this?  Is this a known bug?

Jul 7, 2009 at 12:22 AM

I can't try to repro this as I currently don't have a shared drive.  Found this post though - http://www.codeplex.com/entlib/Thread/View.aspx?ThreadId=17297 and the topic is the same.  Maybe you could try it out also,  fsimonazzi didn't got any feedback.

 

Sarah Urmeneta
Global Technology & Solutions
Avanade, Inc.

entlib.support@avanade.com

Jul 7, 2009 at 1:27 AM

Sarah,

thank you for the post info.  You're gold to this discussion group.  I am contacting fsimonazzi to find out details how to reproduce this error with debug info.

 

thanks,

- Roma

Jul 7, 2009 at 1:31 AM

You can do that by downloading the EntLib PDBs.  For information on how to use it, refer to this thread - http://entlib.codeplex.com/Thread/View.aspx?ThreadId=39988

 

Sarah Urmeneta
Global Technology & Solutions
Avanade, Inc.

entlib.support@avanade.com