Why does entlib 6.0 need .net 4.5?

Topics: Enterprise Library Core, Exception Handling Application Block, Logging Application Block
Jan 27, 2014 at 4:10 PM
We have an application that is deployed in XP, Vista, 7 and 8 in 32 and 64 bits machines in multiple languages in many countries.

Why should this application upgrade to .net 4.5 to use the new features in entlib 6.0?
Jan 28, 2014 at 12:55 PM
One reason is that some features (such as Semantic Logging) depend on .NET 4.5 features (EventSource). If upgrading to .NET 4.5 is not feasible in your environment then can still use Enterprise Library 5 which runs on .NET 3.5, .NET 4.0 and NET 4.5.

~~
Randy Levy
entlib.support@live.com
Enterprise Library support engineer
Support How-to