Error during database operation - Inaccessible logs: Application

Topics: Data Access Application Block
Jan 16, 2009 at 3:30 PM
Hi.
I using C# application (bApp.exe) working with Oracle Database and using this Microsoft.Practices.EnterpriseLibrary:

Microsoft.Practices.EnterpriseLibrary.Common, Version=1.1.0.0, Culture=neutral, PublicKeyToken=xxxxxxxxxxxxxxxxxxx Type: Library
Name: Microsoft.Practices.EnterpriseLibrary.Configuration, Version=1.1.0.0, Culture=neutral, PublicKeyToken=yyyyyyyyyyyyyyyyyyyyy Type: Library
Name: Microsoft.Practices.EnterpriseLibrary.Data, Version=1.2.0.0, Culture=neutral, PublicKeyToken=zzzzzzzzzzzzzzzzzzz Type: Library
Modification date: 20.10.2005

Trouble:
Application installed on Microsoft Windows Server 2003, user with administrative rights has no problems, but If user profile has no administration rights, in same cases  error appears:

Error during database operation. The type initializer for "Microsoft.Practices.EnterpriseLibrary.Data.Instrumentation.DataConnectionFailedEvent"
threw an exception. The source was not found, but some or all event logs could not be searched.
Inaccessible logs: Application.

The problem in:
GetDBParameterValue()->db.ExecuteNonQuery->DBCommandWrapper

Very strange things: bApp.exe in certain cases working fine without admin privileges.
For example: in one folder bApp.exe - working fine, but the same copied version bApp1.exe - don't work, in another folder bApp.exe may be work or not.

User has fullrights on programm folder.

p.s. - on Microsoft  site I found only this distributes of Enterprise Library:
EnterpriseLibraryJune2005.exe 1.1
Enterprise Library January 2006.exe 2.0
Where I can found my 1.2 version?

Jan 17, 2009 at 3:38 AM
Found this thread, see if it helps..
http://community.codesmithtools.com/forums/p/2859/11852.aspx

There's no 1.2 version of EntLib, the version released after 1.1 is already 2.0 and the next was 3.0.


Sarah Urmeneta
Global Technology & Solutions
Avanade, Inc.
entlib.support@avanade.com
Feb 11, 2009 at 1:08 PM
I used installutil but it's not solve all problems.

Programs that don't work write in Application system log message:
Perflib
1008
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
The Open Procedure for service ".NETFramework" in DLL "C:\WINDOWS\system32\mscoree.dll" failed. Performance data for this service will not be available. The Status code returned is the first DWORD in the attached data.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0000: 05 00 00 00

Now I have 4 programs in different path and 2 running well and 2 fail.
Where i rename running progs in other name, it stop running and i got the same error message.

Also I found next that the running well programs added in registry:
HKLM\SOFTWARE\MICROSOFT\Windows NT\CurrentVersion\AppCompatFlags\Layers\
with LUA param

I try add addition programs to this key, restart server but the programs don't start anyway.

Any ideas?
Feb 12, 2009 at 2:39 AM
Edited Feb 12, 2009 at 2:41 AM
But you're not getting the previous error now, aren't you?  I'm not sure if the error you're encountering now is caused by DAAB but anyway, trying running the Install Instrumentation also included in EntLib. I tried googling "Perflib 1008", returned a lot of results (check it out also), read some that might be related to performance counters.


Sarah Urmeneta
Global Technology & Solutions
Avanade, Inc.
entlib.support@avanade.com
Feb 13, 2009 at 1:50 PM
Solved!

Under administrator user setting  in program property - "Use administrative rights"

[HKLM\SOFTWARE\MICROSOFT\Windows NT\CurrentVersion\AppCompatFlags\Layers\aaa.exe LUA]

Now all working fine under non administrator user
Feb 16, 2009 at 1:54 AM
Thanks for the Info.

Valiant Dudan
Global Technology and Solutions
Avanade, Inc.
entlib.support@avanade.com