Upgrading from 3.1 to 5.0

Topics: Caching Application Block
Jan 14, 2013 at 12:11 AM

Hi, are we expected to create our own cache manager in 5.0?

I'm upgrading from 3.1 to 5.0 and am getting an invalid constructor exception when using the cache manager that comes with EntLib. Was all working fine in 3.1.

Full details on this stack overflow post.

Thanks for any help.

Jan 14, 2013 at 12:58 AM

Never mind, I figured it out after inspecting the stack trace more closely.

Turns out it was our custom IAuthorizationProvider that wasn't implementing the required constructor.