What is the minimum version of the Azure SDK is required to use Autoscaling Application Block

Topics: Autoscaling Application Block ("Wasabi")
Dec 10, 2012 at 9:49 PM

Documentations is saying v1.6 (see below), but when use 1.6 we get an error that v1.7 is required.  Is the documentation not up todate or could it be something else in the project that requires v1.7 however the error message explicitly calls out the application block.

Enterprise Library 5.0 Integration Pack for Windows Azure

http://msdn.microsoft.com/en-us/library/hh680918(PandP.50).aspx

 System Requirements
For the application blocks:
• Operating systems: Windows 7 Professional or higher, 32-bit and 64-bit; Windows Server 2008 R2 or Windows Server 2008.
• Windows Azure Tools for Visual Studio and Windows Azure SDK v1.6 (all-in-one installer can be found at http://www.microsoft.com/windowsazure/sdk).
• Additionally, in order to run unit tests, Moq is required (v4.0 or later). It will be installed automatically if you install the Enterprise Library Integration Pack for Windows Azure Source package via NuGet.
• Optionally, in order to use the Logging Application Block Logger, the Microsoft Enterprise Library 5.0 Logging

Dec 14, 2012 at 3:49 AM

As far as I'm aware of, v1.6 should be fine.  What is the exact behavior and message you are seeing?

--
Randy Levy
entlib.support@live.com
Enterprise Library support engineer
Support How-to