Installation ended prematurely because of an error...?

Topics: General discussion
Jan 29, 2007 at 7:37 PM
Hi,

New to EL App Blocks. Would like to start using it but I cannot get it installed on my machine. XP Pro SP2, VS2005 (.Net 2). Nothing else weird. had VS2003 but uninstalled it.

The error is abrupt so no logs get created and there's no other info. All the Event Viewer shows is this:
Product: Enterprise Library for .NET Framework 2.0 - January 2006 -- Installation operation failed.

Is there a Zipped version of this anywhere so I can install it(with instructions) manually? Or are there switches on this installer to get some info out of it to see what's up? Or are there registry keys that I can manipulate to get this installed?

Your help is appreciated!

Thanks.
Jan 29, 2007 at 11:59 PM
I've never had an install error so I can't give you much guidance as to the problem. I am wondering if it is a corrupted download by chance. You could try re-downloading it and try installing again.

There is only 1 download that I know of and all it requires is .NET 2.0. I have installed it alongside other versions of EntLib and with both VS 2003 and VS 2005 and it has never complained.

I don't know if you have access to another PC or laptop to try the install as well and then you can just copy the files to your PC.

Regards,

Dave

__________________________

David Hayden
Microsoft MVP C#
Jan 30, 2007 at 2:27 PM
Thanks for your reply.

If I install on another machine and copy over, do I need to run regasm or gacutil on the files?

Thanks,
--PhB