MS Patch to .NET Framework 1.1 causes ACA .NET 3.0 to fail when loading configuration

Topics: Cryptography Application Block
Oct 1, 2012 at 10:37 PM

Hi there,

 

Our Avanade developed application stopped working when the latest patch to the MS .NET Framework 1.1 was released. Currently we are not deploying the patch but we will need to eventually. Is there a fix for Avanade ACA .NET 3.0 and 3.1 to work around the security issue? Here is the error:

 

An unhandled exception of type 'Avanade.ACA.Configuration.AcaConfigurationValidationException' occurred in avanade.aca.configuration.dll

 

Additional information: The following configuration nodes are invalid...

 

Master Key at path Application/Master Key.

Failed to create the master key instance

 

 

 

Any help would be greatly appreciated. Thanks

 

Stacey Hamilton

PDSL-Application-Support

Innovapost

stacey.hamilton@innovapost.com

Oct 4, 2012 at 7:52 AM

ACA.NET (Avanade Connected Architecture) was a framework built by Avanade Inc.  Microsoft licensed portions of this framework for inclusion in Enterprise Library 1 so the two are somewhat related but are not the same. 

Your best bet would probably be to contact Avanade or, if you have source code, to debug the framework to determine what is causing the error.

--
Randy Levy
Enterprise Library support engineer
entlib.support@live.com 

Dec 3, 2012 at 1:41 PM

Hi,

 

Do you find an issue to this problem?

 

Thx in advance

Dec 5, 2012 at 12:24 AM

please email me at staceyham01@hotmail.com for solution.

Dec 5, 2012 at 10:26 AM

Hi,

 

Thx but found the solution: After installing an ACA 3.1 Patch for the masterKey all works good