Source installation fails?

Topics: General discussion
Nov 8, 2008 at 9:37 PM
I try to install the Enterprise Library 4.1 and it seems to succeed but then the installer launches a source code installer and I am met with the error:

    This system administrator has set policies to prevent this installation.

I am the system administrator. I am thinking it is a permission issue. I have created the source folder and given everyone full control but there must be something else. Any ideas on how I can avoid this error?

Thank you.

Kevin
Nov 10, 2008 at 2:00 AM

Hi Kevin,

May i know what OS are you using? You can go through this link:
http://www.lyalin.com/Blog/archive/2008/10/14/enterprise-library-4.0-error-installing-source-samples.aspx
it discusses the same error as you've encountered but on the Ent Lib 4.0. As a workaround, you can run a command prompt as administrator and run the source code installer MSI.


Valiant Dudan
Global Technology and Solutions
Avanade, Inc.
entlib.support@avanade.com

Nov 10, 2008 at 5:17 AM
Thank you for your response.

I am running Windows 2008 Server.

As suggested I ran as Administrator (not simply with Aministrator privelages) and it seemed to work. I was hoping that the problem could be solved by simply assigning the correct permissions to the installation folder but it seems that is not enough. Thanks again.

Kevin

---- AvanadeSupport <notifications@codeplex.com> wrote:
> From: AvanadeSupport
>
> Hi Kevin,May i know what OS are you using? You can go through this link:
> http://www.lyalin.com/Blog/archive/2008/10/14/enterprise-library-4.0-error-installing-source-samples.aspx
> it discusses the same error as you've encountered but on the Ent Lib 4.0. As a workaround, you can run a command prompt as administrator and run the source code installer MSI.
>
>
> Valiant Dudan
> Global Technology and Solutions
> Avanade, Inc.
> [email removed]
>
>
Nov 12, 2008 at 5:02 PM
Hi Kevin,

This is an issue with group policies for Windows Installer, not with ACLs or UAC. EntLib's source code MSI is unmanaged (in the Windows Installer sense), and certain group policy settings prohibit installing such unmanaged MSIs.

Please check the registry entries under HKLM\Software\Policies\Windows\Windows Installer and HKCU\Software\Policies\Windows\Windows Installer; I don't recall the exact value names and I don't have the information handy, but they should be easy to identify. If you find such values, you'll need to find out why they are there; it could be due to group policies pushed by the organization where your server resides, or just default values in Windows Server 2008.

An alternative is to grab the source code from the codeplex site at http://www.codeplex.com/entlib/SourceControl/ListDownloadableCommits.aspx.

Hope this helps,
Fernando