Problems installing Enterprise Library 5.0 Optional Update

Topics: Building and extending application blocks, Enterprise Library Core, General discussion
Jul 27, 2012 at 3:27 AM
Edited Jul 27, 2012 at 3:29 AM

Hello to everyone.

The library looked interesting and wanted to try it so after reading a bit the documentation I downloaded the 11MB Optional Update 1 msi installer (11MB) and followed these steps to try to make it work with no success:

1.-  After running the package marked all the features to be installed
2.-  Launched the Optional Update 1 Source Installer
3.- Changed the Working Copy Location to the folder "Program Files\Enterprise Library 5.0\EntLib50Src"
4.- Selected to Build the application blocks
5.- Open my Visual Studio Proyect and on the Solution Property selected "machine default", getting the error "Cannot retrieve the configuration set name. The editor will not be launched"
6.- Then changed the property to
EntLibV5Src and got the error "Could not load file or assembly 'Microsoft.Practices.Unity, Version=2.1.505.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies"
7.- Copied the Microsoft.Practices.Unity dll contained in "Program Files\Microsoft Enterprise Library 5.0\bin" into "Program Files\Enterprise Library 5.0\EntLib50Src"
8.- Tried launching again the editor from Visual Studio and I got the error "XamlParseException"
9.- Uninstalled everything and repeated all the steps leaving the source of the
Working Copy default location on "My Documents\EntLib50Src" but it didn't work either.

So I gave up on installing the update and downloaded the Microsoft Enterprise Library 5.0 published on 4/20/2010. Repeated the steps from 1,3,4,6 (chosing EntLibV5Src or Microsoft Signed) and all worked with no errors.

I would really appreciate your insight about how to get the updated version installed with all features working tho. I've looked a lot for a solution online and there is no reference about this particular issue, so this would be good as a future reference as well.

Thank you very much!.

Jul 27, 2012 at 6:41 AM

You can apply an in place upgrade from Enterprise Library 5.0 to Enterprise Library 5.0 Optional Update 1 by:

  1. Renaming the Enterprise Library 5.0 Optional Update 1.msi file to Enterprise Library 5.0.msi 
  2. Executing the following command from the command prompt:

msiexec /i "Enterprise Library 5.0.msi" REINSTALLMODE=vomus REINSTALL=ALL

Randy Levy
Enterprise Library support engineer 

Jul 27, 2012 at 3:03 PM

Hi Randy.

Thanks for your answer. Once having the Microsoft Enterprise Library 5.0 published on 4/20/2010 version installed the update hooked following your instructions.

There seem to be an issue with clean installs of the Update tho because I couldn't make it as you have noticed. Maybe there is something I was missing if so then is a good reason to document that for your team.

Best Regards!.