4.1 install failed even after uninstalling 3.1, 4.0

Topics: General discussion
Oct 30, 2008 at 3:23 PM

I cannot install version 4.1, even after uninstalling 3.1 and 4.0 using Add/Remove Programs. 

The error I get says: This version of the Enterprise Library cannot be installed side-by-side
with version 4.0.  Plese uninstall Enterprise Library V4.0 and try again.

I even removed all directories in %programfiles% that referred to those older versions.

I also removed C:\EntLib3Src and C:\EntLib4Src directories.

I also wrote a PowerShell script to unGAC all assemblies that begin with Microsoft.Practices.

Is there a install log that tells me specifically what the V4.1 installation encountered that made
it stop?

 

 

Oct 30, 2008 at 3:57 PM
Hi,

this is answered in this post: 

http://www.codeplex.com/entlib/Thread/View.aspx?ThreadId=38819

Hope this helps.


.Kratos