Does EntLib4 work with VS2005 / NET 2.0 ?

Topics: General discussion
Oct 30, 2008 at 6:58 AM
Edited Oct 30, 2008 at 7:04 AM
Dear "gurus":

Does Enterprise Library 4 work with VS2005 / NET 2.0 ?

Copying the (EntLib4) dll file Microsoft.Practices.EnterpriseLibrary.Data.dll to my project directory and including it in the project references, and then compiling the project produces no errors. I assume it is safe to use?

Is there any compelling reason that it might not work with VS2005 ie.  are there any dependencies in the source that are specific to NET 3.0 /3.5 ?

Will there be any problems down the line if I include other blocks say Configuration and Logging?

Thanks in advance for any light shed on this.
Oct 30, 2008 at 7:11 AM
Entlib 4 was compiled with and targetted at .NET 3.5. The main reason for this was the use of WMI.NET 2 for instrumentation.

If it works for you under .NET 2.0, great, but it's not a supported scenario and I'm afraid you're on your own.