General Upgrade Questions

Topics: General discussion
Dec 28, 2006 at 2:22 PM
Hi, I hope this is the place for the following questions-
We have several applications running in .NET v1.1 which use the Enterprise Library for .NET Framework 1.1, June 2005. We are switching to VS 2005 (.NET 2.0) for all new development so I have downloaded the Enterprise Library for .NET Framework 2.0. Now my question is can the earlier version coexist with the new version? Would it be better to upgrade the earlier version of the Library to the 2.0 version and if so can I do that with out upgrading the applications to .NET 2.0?

Thanks for any help.
Dec 28, 2006 at 7:27 PM
The short answer is yes - EntLib 1.1 and 2.0 can co-exist on the same machine.

When you download and install EntLib 2.0, read the section entitled Introduction to the Enterprise Library > Migration Information. This gives good information on side-by-side execution as well as tips for partial migration, etc.

Regards,

Dave

______________________

David Hayden
Microsoft MVP C#
http://www.davidhayden.com/
May 25, 2007 at 7:13 AM
Hi, I just installed the EL and I'm looking for the migration information. Yet the Documentation icon doesn't seem to work?

Any ideas?