Support for .Net 2?

Topics: General discussion
Dec 27, 2006 at 10:15 PM

Since .Net 3 is .Net 2 plus the winfx extensions will it be possible to have .net 2 support for entlib 3 (as many projects are only now moving onto .net 2)?

Many Thanks,

Dec 27, 2006 at 10:29 PM
.NET 2.0 is supported.

The System Requirements in the current ReadMe File mention the following requirements for Enterprise Library 3.0:

To install and run this release of Enterprise Library, you must have the following software installed:

· Microsoft .NET Framework 2.0 or 3.0
· Microsoft Visual Studio 2005




David Hayden
Microsoft MVP C#
Dec 29, 2006 at 1:44 AM
Hi John -

We plan on supporting both .NET 2.0 and 3.0 with the EntLib v3 release. Some new features will depend on .NET 3.0, however we plan to isolate this functionality into new assemblies wherever possible, so that most of the functionality continues to work in .NET 2.0 as well.

In the December CTP, the only .NET 3.0 dependency is in the application block factory (since we use the WF type picker). In subsequent releases, we'll include some new assemblies/projects that will make it easier to use the blocks with WCF. These assemblies will obviously require .NET 3.0, but the blocks themselves should not.

Dec 30, 2006 at 9:41 AM
Hi Guys,

Thanks for the quick responses. When this project was first announced I quickly came over to the site and was pretty sure that I read that it required .Net 3. I posted the question to find out why. I'm glad that you are supporting .Net 2 and 3 as I think it will allow a lot more developers to actually use it.