Migrating from Enterprise Library 3.1 May 2007 to 4.0 May 2008

Topics: Enterprise Library Core, General discussion
Jun 17, 2008 at 9:41 PM
I have a Visual Studio 2008 Windows Forms application that targets .NET 3.5 that references the DLLs from Enterprise Library 3.1 May 2007.

Now that 4.0 Enteprise Library May 2008 has been released I would like to migrate my existing project to use the new version.

Should I uninstall the 2007 version first or just leave it installed?

If I wanted to do a source control code branch and leave the existing version referencing the 2007 Enteprise Library and then let the new code branch reference the 2008 version would that be ok?

I might like to keep the older version running just in case I have issues with the new Enterprise Library...

Thanks in advance for any advice.
Jun 18, 2008 at 1:01 PM

Hi,

You don't need to uninstall v3.1. Branching should work, although some WMI features need to be installed and only one of the versions can be used at any given time. Btw, are you keeping the EntLib binaries in a Lib folder in your source tree, or you keep references to the binaries from the install folder?

Fernando


 


dadoffourkids wrote:
I have a Visual Studio 2008 Windows Forms application that targets .NET 3.5 that references the DLLs from Enterprise Library 3.1 May 2007.

Now that 4.0 Enteprise Library May 2008 has been released I would like to migrate my existing project to use the new version.

Should I uninstall the 2007 version first or just leave it installed?

If I wanted to do a source control code branch and leave the existing version referencing the 2007 Enteprise Library and then let the new code branch reference the 2008 version would that be ok?

I might like to keep the older version running just in case I have issues with the new Enterprise Library...

Thanks in advance for any advice.