Using EntLib for a Silverlight5 application

Topics: Exception Handling Application Block, Silverlight Integration Pack
Jan 26, 2012 at 6:22 PM

Hi,

Is it possible to use EntLib with a Silverlight 5 application?

More particular, the Exception Application Block.

When i look to download EntLib, i noticed that the requirements say that it only supports Silverlight 5 beta. If it is not yet possible to use it with a Silverlight 5 application, when will it be?

Best Regards,

Peter

Jan 26, 2012 at 9:21 PM
Edited Jan 26, 2012 at 9:24 PM

Yes, you can use Enterprise Library with Silverlight 5. 

I believe the documentation for the Silverlight Integration Pack for Microsoft Enterprise Library 5.0 download is slightly out of  date. 

Silverlight Integration Pack for Microsoft Enterprise Library 5.0 was released in May 2011 when Silverlight 5 was in beta while Silverlight 5 was only officially released in December 2011.

The blog entry Silverlight Integration Pack for Microsoft Enterprise Library 5.0 released! has an overview and links to various resources.

--
Randy Levy
Enterprise Library support engineer
entlib.support@live.com