MsmqDistributor.exe problem in Windows 7 (Error 1075)

Topics: Logging Application Block
Nov 16, 2011 at 3:53 PM


We've used EnterpriseLibrary since version 1.  We have a large application running in production with EL 4.1. 

Now, we're trying to migrate to EL 5.0, but found a particular problem: the MSMQDistributor.exe doesn't want to run on our development machines under Windows 7 32 bit. 

The MSMQDistributor services is installed without problems, but when we try to start it, it fails with the message "Error 1075: The dependency service does not exist or has been marked for deletion".  In the event log we find this message: "The Enterprise Library Distributor Service service depends the following service: Message Queuing. This service might not be installed."

We checked the obvious, and MSMQ is installed and working properly.  We even installed additional MSMQ features (like triggers and active directory integration), but it didn't work.

Does anyone know something about this?  It fails on multiple machines with Windows 7 - 32 bit (Enterprise).

Thanks in advance,

Nov 17, 2011 at 12:08 AM
Edited Nov 17, 2011 at 3:00 AM

That is a strange error -- especially considering MSMQ is working. This article posits that it could be a Broken Windows Management Instrumentation repository.  It might be worth a try but since this is happening on multiple machines it seems like a bit of a long shot.  (Personally, I would take a backup before making any changes.)

I'm curious if you are able to run MSMQDistributor.exe on any other operating systems (e.g. Windows 7 - 64 bit, Windows Server 2008, etc.)?


What do you see if you view the Enterprise Library Distributor Service Properties Dependencies tab?  Does it show MSMQ as a dependency?

I was able to receive the same error if MSMQ was not installed.

I installed MSMQDistributor.exe and then tried to start the service and I received the same error message you did (and the Dependencies tab had no dependencies and the boxes were greyed out) .
I then installed MSMQ and again tried to start the Enterprise Library Distributor Service.  And I received the same 1075 error.
I then uninstalled MSMQDistributor.exe and reinstalled MSMQDistributor.exe and the service then started OK. 


Randy Levy
Enterprise Library support engineer