v4.0 & v3.1 side by side

Topics: Enterprise Library Core, General discussion
May 19, 2008 at 8:20 AM
Hi,

Is it possible to setup v4.0 and v3.1 on the same machine?
I'm doing a lot of presentations on EntLib with VS2005 and VS2008, and it would be very helpful if I can use the same OS for that.
May 19, 2008 at 4:40 PM

Hi,

Most of the features should work. WMI support is very likely among the ones that will not work. The VS configuration tools will work SxS.

Fernando


memilavi wrote:
Hi,

Is it possible to setup v4.0 and v3.1 on the same machine?
I'm doing a lot of presentations on EntLib with VS2005 and VS2008, and it would be very helpful if I can use the same OS for that.


May 20, 2008 at 8:26 PM
I have both 3.1 (May 2007) and 4.0 (May 2008) side-by-side in the GAC.  I have VS 2005 SP1 and VS 2008 SP1 (beta) installed side-by-side on the same machine.  So far, no conflicts detected.

You can go crazy with seeing two sets of everything when using Add Reference dialog in Visual Studio, but other than the need to be careful, it's working OK for me so far.