Does EntLib 4.1 require fx 3.0 or 3.5?

Topics: General discussion
May 17, 2008 at 12:29 AM
I'm starting a new project and I'm thinking of implementing EntLib.  Problem is that the resulting application has to be able to run on Windows 2000 so I'm limited to the the 2.0 framework.  I'm wondering if I can use the new EntLib 4.0 or if I'm going to have to use 3.1.  Anyone know?
May 19, 2008 at 1:55 AM
From the download page

System Requirements

  • Supported Operating Systems: Windows Server 2003; Windows Server 2008; Windows Vista; Windows XP Professional Edition
For all application blocks except for the Unity Application Block, the Enterprise Library core features, and the configuration tools, the minimum requirements are:

  • Microsoft Windows XP Professional, Windows Server 2003, Windows Server 2008, or Windows Vista operating system
  • Microsoft .NET Framework 3.5 or later
  • Microsoft Visual Studio 2008 development system (any of the following editions):

    • Standard Edition
    • Professional Edition
    • Team Edition for Software Developers
    • Team Edition for Software Testers
    • Team Edition for Software Architects
    • Team Suite


stevehiner wrote:
I'm starting a new project and I'm thinking of implementing EntLib.  Problem is that the resulting application has to be able to run on Windows 2000 so I'm limited to the the 2.0 framework.  I'm wondering if I can use the new EntLib 4.0 or if I'm going to have to use 3.1.  Anyone know?