Key problems

Topics: Cryptography Application Block
May 13, 2008 at 1:55 PM
Edited May 13, 2008 at 1:55 PM
Here is the situation. I have encripted a password that in in a config file. My application can decript the password until I move the application to a different machine where I get Padding is invalid and cannot be removed. I have tried a number of ways to recreate the key file on the other machine but, with no success. I have tried export and import. I tried cuting an pasting the key. nothing seems to work.

Any ideas????
May 13, 2008 at 2:52 PM
Hi,

You don't mention if you're using the built in configuration encryption features, or if you're encrypting it yourself with the crypto block. If you're using the former approach, take a look at this article. If you're encrypting configuration with the crypto block, look at this previous thread.

Fernando


jmacary wrote:
Here is the situation. I have encripted a password that in in a config file. My application can decript the password until I move the application to a different machine where I get Padding is invalid and cannot be removed. I have tried a number of ways to recreate the key file on the other machine but, with no success. I have tried export and import. I tried cuting an pasting the key. nothing seems to work.

Any ideas????


May 13, 2008 at 3:21 PM


fsimonazzi wrote:
Hi,

You don't mention if you're using the built in configuration encryption features, or if you're encrypting it yourself with the crypto block. If you're using the former approach, take a look at this article. If you're encrypting configuration with the crypto block, look at this previous thread.

Fernando


jmacary wrote:
Here is the situation. I have encripted a password that in in a config file. My application can decript the password until I move the application to a different machine where I get Padding is invalid and cannot be removed. I have tried a number of ways to recreate the key file on the other machine but, with no success. I have tried export and import. I tried cuting an pasting the key. nothing seems to work.

Any ideas????


Fernando,
Thanks for the help. I just tried exporting and importing again. Don't think I did anything different but, this time is appears to have worked.

Thnaks.