.NET 2.0 with enterprise library 1.1

Topics: Enterprise Library Core, General discussion
May 7, 2008 at 6:27 AM
Hi All,

We are migrating our application from .NET 1.1 to .NET 2.0 . Our application also uses enterprise library 1.1 which we don't want to migrate to enterprise library 2.0.

can we migrate ouu application to .NET 2.0 using entlib 1.1?

whether entlib 1.1 is compatible with .NET 2.0?

Thanks,
Abhishek
May 19, 2008 at 4:56 PM
EntLib 1.1 is compatible with .NET 2.0.

Fernando


arunabhishek wrote:
Hi All,

We are migrating our application from .NET 1.1 to .NET 2.0 . Our application also uses enterprise library 1.1 which we don't want to migrate to enterprise library 2.0.

can we migrate ouu application to .NET 2.0 using entlib 1.1?

whether entlib 1.1 is compatible with .NET 2.0?

Thanks,
Abhishek



May 19, 2008 at 9:44 PM
You will probably want to recompile entlib 1.1 with the .NET 2.0 compiler; back in the day I remember this fixing some weird issues.

May 20, 2008 at 8:25 AM
I would suggest to upgrade to EntLib 3.1 / 4.0 then, this is quite easy in my experience. Only recreating the configs will take some time. All the API changes are well documented, think that's easier then recompiling your own EntLib version. Also if you consider any future upgrade needs.

Check the EntLib 2.0 documentation for the API changes, API's haven't changes a lot from 2.0 to 3.1.

Gerben.