Failed to install enterprise library 3.1 on windows 7 64 bit

Sep 1, 2011 at 3:01 PM

The Installer Information pop up says: "The installer requires the .NET Framework ver 2.0 which is not present on the computer. Please install it an try again. "  After that, I tried install .NET framework 2.0 redistributable x64 on my machine. The Error message I got is : Product alread installed---This product is already installed as part of the operating system.

I know Windows 7 is not in the list of Required System for Enterprise Library 3.1 , but I take it as not updated in time.  Please advise whether it is possible to install enterprise library 3.1 on Windows 7 64 bit. If it is not possible, what is the reason.  If it is possible, what I can do?  Using new Enterprise Library 5.0, our team face two things unexpected code change and new deployment request to admin group which would take a long time.

I appreciate your help!

Sep 2, 2011 at 3:25 AM

Hi,

It seems the installer is looking for .NET Framework 2.0 x86. Is this already installed in your machine?

 

Noel Angelo Bolasoc
Global Technologies and Solutions
Avanade, Inc.
Contact Us

Sep 2, 2011 at 6:50 PM

Hi,

Thanks for reply. I tried to install .NET Framework 2.0 X86, but the installation failed again. It says .NET framework 2.0 can not be installed on 64 bit platform.

Thanks

Heng Yang

Sep 5, 2011 at 6:30 AM

Well I guess the only possible reason is that Windows 7 is not really supported by Entlib 3.1. I'll confirm this to Microsoft and get back to you for update.

 

Noel Angelo Bolasoc
Avanade Software
Avanade, Inc.
Contact Us

Sep 8, 2011 at 5:41 AM
Edited Sep 8, 2011 at 6:00 AM

Hi Heng Yang,

It seems there is a problem with your installer. We got a chance to reproduce it on Windows 7 x64 and it installed fine. Are you using the installer found on this link? If yes, then the possible work around is to download the source and build it or install it on another machine and grab the binaries.

 

Noel Angelo Bolasoc
Avanade Software
Avanade, Inc.
Contact Us