Enterprise Library DAAB 5.0 with Oracle.DataAccess.Client

Topics: Data Access Application Block
Jul 26, 2011 at 1:28 PM

I'm trying to execute a oracle stored procedure by passing an input parameter of type string using DAAB 5.0.

Parameter is being sent as null to the stored proc.

This happens when I use Oracle.DataAccess.Client as provider.

Works fine if System.Data.OracleClient is used as provider

Jul 27, 2011 at 5:31 AM

Did you get any exceptions. Have you already added the necessary provider mappings to your application?

 

Noel Angelo Bolasoc
Global Technologies and Solutions
Avanade, Inc.
Contact Us

Jul 27, 2011 at 8:47 AM

It worked on adding the provider mappings.

Thank you.

Aug 9, 2011 at 4:56 PM
Edited Aug 9, 2011 at 4:57 PM

Hi krishna14

Could you please show how you added the provider mappings?

I have read the guide? (http://devstuffs.wordpress.com/2010/02/04/using-enterprise-library-with-oracle-odp-net-2/) but i don’t understand the procedure to add the mappings.

I have a project working, but when i deploy the application the application doesn’t work

Thanks 

Mar 15, 2012 at 2:53 PM

The link you posted was updated. Check out this link if you still don't understand take a look at the sample.

Sep 4, 2013 at 3:17 PM
And DAAB 6.0 and ODP.NET ?
Editor
Sep 4, 2013 at 3:30 PM
Not officially. The answer at http://stackoverflow.com/questions/17828684/odp-net-in-microsoft-enterprise-library-6-0/17904149#17904149 sums it up quite well.

~~
Randy Levy
entlib.support@live.com
Enterprise Library support engineer
Support How-to