EL5.0 and Windows Server 2003 SP2 compatibility

Topics: Caching Application Block , Enterprise Library Core, Exception Handling Application Block, General discussion, Logging Application Block, Policy Injection Application Block
May 23, 2011 at 10:57 AM

Does anyone know if EL5.0 is compatible with WS2003 SP2?

Although the platform requirements lists only WS2003 R2, we have to run a solution which uses EL5.0 (Unity 2.0, Logging, Exception and Caching blocks) on WS 2003 SP2 – are there any issues?

Thanks,

Robert

May 23, 2011 at 12:02 PM

I believe there shouldn't have any issue. Windows Server 2003 with  SP2 is actually in the list of both Entlib 5 and Unity 2.0 System Requirement and Prerequisite.

Here are the supported OS as per the documentation:

Operating system: Microsoft Windows® 7 Professional, Enterprise, or Ultimate; Windows Server® 2003 R2; Windows Server 2008 with Service Pack 2; Windows Server 2008 R2; Windows Vista® with Service Pack 2; or Windows XP with Service Pack 3.

Hope this helps.

Gino Terrado
Global Technologies and Solutions
Avanade, Inc.
entlib.support@avanade.com

May 23, 2011 at 2:16 PM

Gino,

I think that Windows Server 2003 SP2 is still missing from the list - should it be there?

Looking closer at the history of WS 2003, SP2 is actually a later update than R2  (SP1 - 2003, R2 - 2005, SP2 - 2007). My client (a large enterprise) tends to keep up with SP's, not R's, so I have to target WS 2003 SP2.

From the EL 5.0 perspective, probably any WS 2003 works, but it would be useful to clarify.

Regards,

Robert

May 24, 2011 at 10:37 AM

Hi Robert,

Sorry about that, I honestly got mixed up with the 2. With that being said I really am not sure if there is any issue with WS2003 SP2 specific to Entlib. And would think the best way is to try this out.

Gino Terrado
Global Technologies and Solutions
Avanade, Inc.
entlib.support@avanade.com