Enterprise Library 5.0 installation error

Topics: General discussion
Jan 12, 2011 at 8:56 AM

"This application requires .NET Framework 3.5 SP1. Please install the .net framework then run this installer again"

But the system has already installed .net Framework 4.0. In add remove programs I can see the following two entries:

1: Microsoft .NET Framework 4 Client Profile
2: Microsoft .NET Framework 4 Extended.

Any ideas why the installation is failing?

Jan 12, 2011 at 11:56 PM

Did you also post this one in StackOverflow?  As documented, EntLib should run with either .NET 3.5 or 4.0 so I suggest keep watch on that thread as Chris Tavares (EntLib Dev Lead) and Grigori Melnik (EntLib PM) will likely to provide the answer to this installation issue.

 

Sarah Urmeneta
Global Technologies & Solutions
Avanade, Inc.
entlib.support@avanade.com

Jan 13, 2011 at 4:33 AM

Yes I posted that too. I have updated the stackoverflow topic with repro steps.