Can't start the ConfigTool in Entlib 5.0

Topics: Enterprise Library Core, General discussion
Oct 26, 2010 at 8:26 AM

Hi! I have a problem with the configuration tool of Entlib 5 in one of our projects. We can’t start the Configuration Tool. When we start it, we receive a COMException with the error code: HRESULT 0x88982F50. We downloaded the source code and tried to debug the application, but we receive the error before the constructor is called. Wonder if anyone has a clue to what might be the problem?

Oct 26, 2010 at 8:32 AM
Edited Oct 26, 2010 at 8:36 AM

 I haven't encountered this yet, from where are you opening the configuration tool?  I don't know if this is relevant but what operating system are you using?


Sarah Urmeneta
Global Technology and Solutions
Avanade, Inc.

Oct 26, 2010 at 9:17 AM

Hi! We use Windows XP and have tried to start it from the installation folder, C:\Program Files\Microsoft Enterprise Library 5.0\Bin. We have also built Entlib from the source, and tried to start it from build directory. Same problem! We found this error message:

at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
at System.Windows.SplashScreen.CreateLayeredWindowFromImgBuffer(IntPtr pImgBuffer, Int64 cImgBufferLen)
at System.Windows.SplashScreen.Show(Boolean autoClose)\r\n at Microsoft.Practices.EnterpriseLibrary.Configuration.Console.App.Main() in C:\\EntLib50\\Blocks\\Configuration\\Src\\Console\\obj\\Debug\\App.g.cs:line 0
at System.AppDomain._nExecuteAssembly(Assembly assembly, String[] args)
at System.AppDomain.ExecuteAssembly(String assemblyFile, Evidence assemblySecurity, String[] args)
at Microsoft.VisualStudio.HostingProcess.HostProc.RunUsersAssembly()
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()"

Oct 26, 2010 at 9:26 AM

Which of the four EntLibConfig.exe did you open?  What version of .NET Framework do you have installed on your machine?  I don't know yet what's causing the exception but I would probably try to repro it.  I just don't have the machine setup right now.  I'll get back to you.


Sarah Urmeneta
Global Technology and Solutions
Avanade, Inc.

Oct 26, 2010 at 9:37 AM

Hi! We are using .Net Framework 3.5 and tried all four exe.files with the same result.

Oct 26, 2010 at 10:06 PM

Based on the stack trace, that looks like a pretty serious problem down inside WPF. The Entlib stuff isn't even there yet. Do other WPF applications work on that box?

Also, do you have .NET 3.5 SP1? The service pack is required for Entlib.

I did some searching for that HRESULT and the result I found says it means there's an image codec missing. So it's most likely an environmental thing on that machine, not sure what though.



Oct 27, 2010 at 10:21 AM

Hi! We are using 3.5 SP1 and have tried to re-install Entlib, .Net framework and even VS without getting Entlib Config tool to work. There is one other WPF application working on the machine. The computer has a history of many installations and un-installations, and I guess something is corrupt in the environment. Due to time constraints, we will stop further debugging and re-install the OS.

Thanks for the replies.