Enterprise library 5.0 why still uses v2.0.50727 instead of .net framework 4.0

Oct 22, 2010 at 7:08 PM

I have a project which previously contains .net framework 3.5 and etlerprise library 4.1.

Now to utilize new language features [like parallel programming e.t.c] and just have a single framework[i.e. 4.0]  I have converted my project to .net framework 4.0.

Now what i see is that in the runtime version of the Enterprise library dlls it shows framework version v2.0.50727 instead of my desired 4.0

my need is to just have framework 4.0 on my server machine [let say a simple windows xp machine with just .net framework 4.0]

should i don't have to worry about it?

Oct 23, 2010 at 12:20 AM

.NET Framework 4.0 transparently loads and runs Framework 2.0 assemblies. It's just like loading a 1.1 framework assembly in 2.0. You don't need to install anything but .NET 4.0 on your server.