EntLib3.1 & Visual Studio 2008

Topics: Enterprise Library Core, General discussion
Mar 2, 2008 at 3:24 AM
Hi, I've been trying to install EntLib3.1 in Visual Studio 2008 Pro with GAT/GAX Feb 2008 installed, I got error 2869 and two no message dialogs. What's wrong with it?
Mar 2, 2008 at 4:58 AM
I've had the same error on Vista x64 with VSTS 2008.

This is what's in my eventlog.

The description for Event ID 11001 from source MsiInstaller cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

Product: Enterprise Library 3.1 - May 2007 -- Error 1001.

Product: Enterprise Library 3.1 - May 2007 -- The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2869. The arguments are: ErrorDlg, ,
Mar 2, 2008 at 8:18 PM
Hi,
You can sucessfully install EntLib 3.1 unchecked option Application Block Software Factory.
Hope this help.
Andrzej
Mar 2, 2008 at 10:51 PM
Thanks the pointer. I was able installed only the documentation and source code info. That was very helpful.
Mar 3, 2008 at 12:01 AM
Yep, many thanks, I had to uncheck the AppBlock Software Factory and the Sign Guidance Package. I guess is something related to the Feb Release of GAT/GAX, waiting for EntLib4 right now :P