Calling a stored Procedure in Oracle 10g

Topics: Data Access Application Block
Sep 22, 2010 at 4:14 PM

I had downloaded Enterprise Library 5.0 and working to call Stored Procedure with InPut and OutPut Parameters.

I am not able to call Stored Proc and it is through Error that It did not Found Stored Proc with the Following Name.

I Double checked with Connection String every thing is Fine. 

Any Help is Appretiated



Sep 23, 2010 at 3:00 AM


Personally I haven't used DAAB in Oracle yet. Though the obvious question would be - have you checked in your Oracle Db if the stored proc exist? :-)

Gino Terrado
Global Technology and Solutions
Avanade, Inc.

Sep 23, 2010 at 4:10 AM

Stored Proc Exists in DB.

I am new to Enterprise library first i tried all Data Access hands on Lab to get used to it, most of the samples are Targeted to SQL and there is not much on web regarding this.

Sep 23, 2010 at 2:05 PM

I've tried to reproduce your scenario using the Oracle 10g Express and fortunately was able to call a stored proc without raising an exception that the Sproc cannot be found

For the sake of a sample, here's what my stored proc looks like;



And in my application code

            Database db = EnterpriseLibraryContainer.Current.GetInstance<Database>("MyOracleExpress");
            DbCommand command = db.GetStoredProcCommand("ORACLESPROC"); 
            object result = db.ExecuteScalar(command);


For some references here are some article I found in the net which I hope will help you


Gino Terrado
Global Technology and Solutions
Avanade, Inc.



Sep 24, 2010 at 1:54 AM

Check your connection string as well if it points to the correct database.


Sarah Urmeneta
Global Technology and Solutions
Avanade, Inc.