EnterpriseLibrary 3.0 Error

Jul 6, 2010 at 7:54 AM

Hi there,

I have an encounter on my web application, when I run then I receive following error

Could not load file or assembly 'Microsoft.Practices.EnterpriseLibrary.Logging, Version=, Culture=neutral, PublicKeyToken=b69d2d350639533d' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

I used .net 2008 and installed Microsoft Enterprise Library 3.0 - April 2007, I tried Add referrence to C:\Program Files\Microsoft Enterprise Library 3.0 - April 2007\Bin folders and change all details (version= in web.config but not working and allway received error with version

Please help me resolve this issue



Hiển thị chữ viết theo ngữ hệ La-tinh

Jul 6, 2010 at 8:37 AM

Hi alexquan,

It will indeed error out since the referenced assembly version (3.0) is different from what it is expected/needed ( As per this thread http://entlib.codeplex.com/Thread/View.aspx?ThreadId=82077 version is only available if you have a copy of ACA.NET 4.1.  

Gino Terrado
Global Technology and Solutions
Avanade, Inc.