Unable to install EntLib in GAC (.net 4.0)

May 21, 2010 at 10:23 PM

I have done this a lot of times before and for some reason is not letting me.

I am using Visual Studio 2010 amd have the assemblies signed with strong name file, and when I am trying to add them to GAC the GAC manager says: Your assembly must have a strong name (version and public key).

I have used the sn -T <assembly> and it dispays the public token.

Do you know of any existing problem problem?

May 24, 2010 at 3:52 AM

Are you sure you're deploying to GAC the same assemblies you checked for using the strong name tool?  I'm not aware of any issues on this.  Have you tried installing the ones from the entlib installation folder?


Sarah Urmeneta
Global Technology & Solutions
Avanade, Inc.

May 24, 2010 at 3:59 PM

Yes, I am using those same assemblies.

This is what I did:

1.- sn - k EntLib50.snk

2.- assigned it to each project through the properties window.

3.- compile.

4.- Tried adding it to the assembly cache using the .NET framework Configuration Tool  (I even tried dragging and dropping into C:\windows\assembly)

Is there anything else I missed?


May 24, 2010 at 4:38 PM

I have noticed that if I compile the assembly against .net v2.0 I have no problem. But when I do 4.0 is when I have the problem.

Please try it...

May 24, 2010 at 5:21 PM

never mind guys. The issue was that now the assembly folder has moved. http://msdn.microsoft.com/en-us/library/ee941656.aspx and no longer can use C:\windows\assembly for 4.0 assemblies