How to upgrade to .NET Framework with Enterprise Library 4.1

Topics: Building and extending application blocks
May 14, 2010 at 1:07 PM

How to upgrade to .NET Framework with Enterprise Library 4.1? When I set target framework to 4.0 in Enterprise Library, it cannot compile. Any good solution to do it?

May 14, 2010 at 3:42 PM

Entlib 4.1 is not supported on .NET 4.0, and it definitely won't compile when targeting the 4.0 framework.

Your best bet is to just try the 4.1 binaries directly. There's no need to recompile targeting .net 4.0, the 4.0 CLR will load and run 3.5 assemblies just fine. Why do you feel the need to recompile them targeting 4.0?

We have not, and will not, be doing any testing on Entlib 4 against .NET 4. The supported version on .NET 4 is Enterprise Library 5.0. That being said, most of Entlib 4.1 will probably just work.