Does Enterprise Library 3.1 Support Window 7?

Topics: General discussion
Apr 14, 2010 at 9:56 AM
I am trying to install Enterprise Library 3.1 on Window 7, the installation abort by showing following error message: The installer requires the .NET Framework ver. 2.0 which is not present on the computer. Please install it and try again. As far as I know Window 7 shipped with .NET Framework 3.5 SP1, which includes .NET 2.0 with SP2 and .NET 3.0 with SP2 as prerequisite. I have cross checked using .NET Framework verification tool which detects successfully .NET Framework 2.0 SP2 on my machine. I have also tried to install explicitly .NET Framwork 2.0 (was successfully installed) and .NET Framework 2.0 SP1 got error The product is not supported on Vista Operating System (wrong message I am running it on Window 7). I have also reinstalled Microsoft .NET Framework 3.5.1 using Turn Windows features on or off. Does Enterprise Library looks for specific files of .NET Framework 2.0 which are not available on window 7?
Apr 15, 2010 at 1:36 AM
Edited Apr 15, 2010 at 1:37 AM

I really haven't tried installing 3.1 on Win7 but do you have VS2005 installed?  'Coz it's actually listed as one of the system requirements for entlib 3.1.


Sarah Urmeneta
Global Technology and Solutions
Avanade, Inc.