CMAB For dotnet 2.0 above

Topics: General discussion, Pre-release discussions
Jan 13, 2008 at 7:57 AM
Hi,

I am planning on migrating some of the old applications that I have to dotnet 3.0. However, the old application is using CMAB (pre-release before enterprise library), i.e. http://msdn.microsoft.com/library/en-us/dnbda/html/cmab.asp. Is there any migrated library that directly has one-to-one functionality to this library?
Is there any migration path for this library.

Thanks.

Jan 14, 2008 at 6:08 AM
A lot has changed from the old Configuration Management Application Block to .NET 2.0+ configuration, and unfortunately there isn't any direct migration path. EntLib 1.x did have a Configuration Application Block based on the old CMAB, and EntLib 2.x-3.x includes a QuickStart called Configuration-Migration which demonstrates how to implement the same scenarios using .NET 2.0 configuration. It's not ideal, but it's probably your best bet.

Tom