Enterprise Library and Visual Web Developer 2008 Express Edition

Topics: General discussion
Jan 9, 2008 at 2:03 PM
Hi all,

Can I use with Visual Web Developer 2008 Express Edition the Enterprise Library (May 2007 - 3.1)?

Thanks!
Boah
Jan 10, 2008 at 1:09 AM
Hi,

You won't be able to use the guindance packages or the integrated configuration tool, but the runtime and stand alone configuration tool should work.

Fernando
Jan 12, 2008 at 7:38 PM
Sure?

In the help files or download requirement list I don't see Visual Web Developer 2008 Express Edition.
Jan 15, 2008 at 1:50 AM
Well, Visual Web Developer 2008 didn't exist when the May 2007 version was released.

As a general rule, tools (like the guidance packages or the integrated configuration tool) will not work in the Express versions of Visual Studio. The runtime assemblies, and the stand alone configuration tool, do not depend on a specific tool and they can be used with just plain .NET SDK.

I haven't used that particular SKU, but as long as you can add a reference to an assembly and write code that uses the assembly you should be fine.

Fernando
Jan 15, 2008 at 10:14 AM
Okay, thank you very much.
I will give it a try.

Boah