Writing to custom event log fails

Topics: Exception Handling Application Block, Logging Application Block
Oct 16, 2007 at 2:55 PM
All,

I've set up a custom event log and made the changes in my config file using the configuration tool. When the application encounters an error nothing shows up in the event log. If I change my config file to point to the Application log the error shows up as expected.

Can anyone help me get this problem fixed?

Thanks
Oct 17, 2007 at 1:40 AM
Id suggest you tell us the steps you took to "setup" the custom event log on the machine and if your trying to write to it from IIS, Hosted, or Native :)

Also, you could add the working EventLogListener to the Logging -> Special Sources -> Logging Errors & Warnings so any problems encountered by EntLib (i.e. unable to perform action with xListener) will be recorded to a reliable source.
Oct 17, 2007 at 11:17 AM
Thanks for the reply. I got it working late yesterday. Reconfigured my source properties to the properties of the event log and the messages started showing up. I will set up the Special Sources warnings for future use.

Thanks again!


Enliven wrote:
Id suggest you tell us the steps you took to "setup" the custom event log on the machine and if your trying to write to it from IIS, Hosted, or Native :)

Also, you could add the working EventLogListener to the Logging -> Special Sources -> Logging Errors & Warnings so any problems encountered by EntLib (i.e. unable to perform action with xListener) will be recorded to a reliable source.

Nov 8, 2007 at 4:46 PM
Edited Nov 8, 2007 at 4:48 PM
Thanks for your post, I had the same problem. However, this brings me to my next problem. Is there some way to have the entlib automatically create the custom event log and the corresponding source?